WordPress 4.5 Release Affects LiveEditor Functionality

WordPress 4.5 will be released on April 12th 2016.  This new WordPress update changes some of the core Javascript files which affect the LiveEditor inside OptimizePress.

This means that if your site is updated to version 4.5 of WordPress, the LiveEditor will no longer function correctly.

What Issues Will I Experience?

If you are using a version of OptimizePress older than 2.5.4, clicking any button in the LiveEditor will trigger the "Add New Row" dialog box. You will not be able to effectively edit or update your pages

Existing published pages will remain unaffected by this - it only affects your ability to modify pages.

How to Resolve this issue

1. If you're using version 2.5.4 or above of OptimizePress:

This issue has been patched and you don't need to do anything - your LiveEditor should work as normal

2. If you're using a version of OptimizePress between version 2.4.0 and 2.5.4:

You should update to the latest version via the automatic OptimizePress updater or by downloading the latest version from the members hub.

You can also use our patching tool to patch your site if you no longer have access to updates for these versions.  Simply install the patching plugin and go to Tools > OP Patches and then follow the on-screen instructions.  You can download the patching  plugin here 


3. If you are using a version previous to 2.4.0 and you do not have an active support and updates license:

You will need to login to your OptimizePress account at http://members.optimizepress.com and follow the instructions to renew your support & updates subscription to get access to the most recent releases of OptimizePress (look for the blue bar at the top of the page once logged in).

We have provided patched versions of OptimizePress dating back 1 year (version 2.4.0), but further back than this, you will be required to renew your support and updates license so you can access the latest versions of our platform as well renewing your support for another 1 year.

Please note: Your "live" published pages will not be affected by this update, so your visitor facing pages will still work fine, this update only affects your ability to edit pages inside the LiveEditor

Important Note

After you have updated your site, if you still experience the same problem, it's likely that your browser has cached the old javascript files from the LiveEditor. We recommend fully clearing your browser cache, cookies and temporary files, or switch to a different browser to check this.

Other 4.5 Related Issues

>> OverlayOptimizer Not Opening or Page Reloading

If you are experiencing issues with the OverlayOptimizer not opening after updating your site, this might be due to some custom code you have inside Page Settings > Other Scripts > Header/Footer sections 

Some Javascripts which were added or included with the templates for smooth scrolling or other functions, these have been found to break some other page elements in the latest WordPress 4.5 

To fix this, for now we advise removing this code to stop this issue from occurring. We will be updating our users on fixed code as soon as possible for this function