Parse error: syntax error, unexpected T_STATIC, expecting ...

If you receive an error similar to this when activating or using the PlusPack plugin:

Parse error: syntax error, unexpected T_STATIC, expecting ')' in /home/yoursite/public_html/wp-content/plugins/optimizePressPlusPack/oppp.php on line 72

This error is because your server/website is running a very outdated version of PHP (lower than 5.3)

 

We always recommend running 5.3 of PHP or higher. PHP 5.2 is very outdated now (it was released in 2006) so it doesn't support some of the more updated functionality we use in our platform and you'll experience errors if you try to use it

We recommend contacting your hosting company and ask them to increase your PHP version to a minimum of 5.3. You'll see that the error message in your WordPress dashboard disappears once this has been done. Any good hosting company will be able to assist with this